Имя:
Пароль:
Забыли пароль?
Регистрация
ГлавнаяПрограммыБаза знанийПомогите найти программуВопросы системным администраторам
Поиск по базе знаний

Поиск по наименованию:

Формулы в Excel: создание и расчет

К списку материалов
Тема: Программное обеспечение

Автор: Дмитрий
Опубликована: 18.03.2012

Популярность=283 (+204/-79)
Формулы в Excel: создание и расчетОсновы написания формул в программе Excel 2003 и Excel 2007. Вставка формул из стандартного списка программы.

Формулы в Excel — это его основная суть, то, ради чего и была создана эта программа компанией Microsoft. Формулы позволяют произвести расчеты значений ячеек на основе данных других ячеек, причем если исходные данные поменяются, то результат вычислений в ячейке, где стоит формула пересчитается автоматически!

Создание формул в Excel

Рассмотрим работу формул на самом простом примере — сумме двух чисел. Пусть в одной ячейке Excel введено число 2, а в другой 3. Нужно, чтобы в третье ячейке появилась сумма этих чисел.

Задача суммирования

Суммой 2 и 3 является, конечно же, 5, но вносить пятерку вручную в следующую ячейку не надо, иначе теряется смысл расчетов в Excel. В ячейку с итогом необходимо ввести формулу суммы и тогда результат будет вычислен программой автоматически.

Вывод результата

В примере вычисление выглядит простым, но когда числа большие или дробные без формулы просто не обойтись.

Фомулы в Excel могут содержать арифметические операции ( сложение +, вычитание -, умножение *, деление /), координаты ячеек исходных данных (как по отдельности, так и диапазон) и функции вычисления.

Рассмотрим формулу для суммы чисел в примере выше:

=СУММ(A2;B2)

Каждая формула начинается со знака «равно». Если Вы хотите добавить в ячейку формулу, написав ее вручную, то именно этот знак следует написать первым.

Далее в примере идет функция СУММ, которая означает что необходимо произвести суммирование некоторых данных, а уже в скобках у функции, разделенные точкой с запятой, указываются некоторые аргументы, в данном случае координаты ячеек (A2 и B2), значения которых необходимо сложить и поместить результат в ту ячейку, где написана формула. Если бы Вам требовалось сложить три ячейки, то можно было бы написать три аргумента у функции СУММ, разделяя их точкой с запятой, например:

=СУММ(А4;B4;C4)

Когда требуется сложить большое количество ячеек, то указывать каждую из них в формуле займет очень много времени, поэтому вместо простого перечисления можно использовать указание диапазона ячеек:

=СУММ(B2:B7)

Диапазон ячеек в Экселе указывается с помощью координат первой и последней ячеек, разделенных знаком «двоеточие». В данном примере производится сложение значений ячеек, начиная с ячейки B2 до ячейки B7.

Сумма диапазона ячеек

Функции в формулах можно соединять и комбинировать как Вам необходимо для получение требуемого результата. Например, стоит задача сложить три числа и в зависимости от того, меньше ли результат числа 100 или больше, домножить сумму на коэффициент 1.2 или 1.3. Решить задачу поможет следующая формула:

=ЕСЛИ(СУММ(А2:С2)<100;СУММ(А2:С2)*1,2;СУММ(А2:С2)*1,3)

Вычисление с условием

Разберем решение задачи подробнее. Использовалось две функции ЕСЛИ и СУММ. Функция ЕСЛИ всегда имеет три аргумента: первый — условие, второй — действие в случае, если условие верно, третий — действие в случае, если условие неверно. Напоминаем, что аргументы разделяются знаком «точка с запятой».

=ЕСЛИ(условие; верно; неверно)

В качестве условия указано, что сумма диапазона ячеек A2:C2 меньше 100. Если при расчете, условие выполнится и сумма ячеек диапазона будет равна, например, 98, то Эксель выполнить действие указанное во втором аргументе функции ЕСЛИ, т.е. СУММ(А2:С2)*1,2. В случае же, если сумма превысит число 100, то выполнится уже действие в третьем аргументе функции ЕСЛИ, т.е. СУММ(А2:С2)*1,3.

Встроенные функции в Excel

Функций в Excel огромное количество и знать все просто невозможно. Некоторые часто используемые запомнить можно, а некоторые Вам понадобятся лишь изредка и помнить их название и тем более форму записи очень сложно.

Но в Экселе имеется стандартный способ вставки функций с их полным списком. Если Вы хотите добавить какую-то функцию в ячейку, то кликните по ячейке и выберите в главном меню вставку функции. Программа отобразит список функций и Вы сможете выбрать ту, которая необходима для решения задачи.

Чтобы вставить функцию в Excel 2007 выберите в главном меню пункт «Формулы» и кликните на значок «Вставить функцию», либо нажмите на клавиатуре комбинацию клавиш Shift+F3.

Вставка функции в Excel 2007

В Excel 2003 функция вставляется через меню «Вставка»->«Функция». Так же работает и комбинация клавиш Shift+F3.

Вставка функции в Excel 2003

В ячейке на которой стоял курсор появится знак равенства, а поверх листа отобразится окно «Мастер функций».

Выбор функции

Функция в Excel разделены по категориям. Если Вы знаете к какой категории может относится предполагаемая Вами функция, то выбирайте отбор по ней. В противном случае выберите «Полный алфавитный перечень». Программа отобразит все имеющиеся функции в списке функций.

Пролистывайте список и выделяйте мышью наименование, заинтересовавшей Вас функции. Чуть ниже списка появится ее форма записи, требуемые аргументы и краткое описание, которое разъяснит Вам предназначение функции. Когда найдете то, что нужно, кликните по кнопке «OK» для перехода к указанию аргументов.

Описание функции

В окне аргументов имеются поля с названиями «Число 1», «Число 2» и т.д. Их необходимо заполнить координатами ячеек (либо диапазонами) в которых требуется взять данные. Заполнять можно вручную, но гораздо удобнее нажать в конце поля на значок таблицы для того, чтобы указать исходную ячейку или диапазон.

Окно аргументов функции

Окно аргументов примет упрощенный вид. Теперь необходимо кликнуть мышью на первую исходную ячейку с данными, а затем снова на значок таблица в окне аргументов.

Указание исходной ячейки

Поле «Число 1» заполнится координатами выбранной ячейки. Ту же самую процедуру следует проделать для поля «Число 2» и для следующих полей, если число аргументов функции у вас более двух.

Заполнение всех аргументов

Заполнив все аргументы, Вы уже можете предварительно посмотреть результат расчета полученной формулы. Чтобы он появился в ячейке на листе, нажмите кнопку «OK». В рассмотренном примере в ячейку D2 помещено произведение чисел в ячейках B2 и C2.

Результат произведение чисел

Рассмотренный способ вставки функции является универсальным и позволяет добавлять любую функцию из общего списка стандартных функций Excel.

Смотрите так же:



Согласны ли Вы с автором?
ДаНет

Комментарии
Ал
2012-09-26 08:20:34
Коротко. Ясно. Для начала...
Добавить комментарий
Хотите добавить аватарку к комментариям?
Зарегистрируйтесь и установите ее при регистрации или в настройках пользователя!
Ваш имя:
Код:
Комментарии проверяются модератором сайта.
К списку материалов


Copyright © "Infowall.ru".
Использование материалов сервера в on-line изданиях разрешается при наличии гиппертекстовой ссылки на www.infowall.ru.
Ссылка должна содержать слова: 'Информационный портал' Infowall.ru.
Использование материалов в off-line изданиях возможно лишь с письменного разрешения администрации Infowall.ru.